PDA

View Full Version : Any experience with fixing Urban180 from Light & Motion...



Terpfan
07-05-2013, 11:24 AM
So I was riding in the great rain of Wednesday morning and my light was working fine in blinking mode. I charged it at work. And on the way home, the button for using the light wouldn't depress. 2 days later, same problem. Any idea toward fixing it? I submitted it to L&M's support side for their repair suggestions.

Terpfan
08-13-2013, 08:49 AM
I should add the answer to this is you're basically screwed. L&M said if it's under warranty they'll repair it (it was past that) otherwise they didn't respond to my email when I said it wasn't. Ie, the cost of fixing exceeds the cost of buying a new one. I even tried putting it in a bag of rice to dry it out. I may still tinker some when I have some free time, but alas, it's a paperweight now.

Tim Kelley
08-13-2013, 09:04 AM
Did you order online or get it through a shop? If it's through a shop you might have had better luck working through them.

off2ride
08-13-2013, 10:04 AM
L&M is slow as molasses when it comes to responding to questions. I started a case (It is now a cold case) about a Vis 180 tail light that I bought from Spokes 3 years ago. I told them that the light mounting design builds up a lot of grime and dirt while riding in the rain. Therefore the pivot design seizes and eventually will break if forced open. No response to this day.



So I was riding in the great rain of Wednesday morning and my light was working fine in blinking mode. I charged it at work. And on the way home, the button for using the light wouldn't depress. 2 days later, same problem. Any idea toward fixing it? I submitted it to L&M's support side for their repair suggestions.